Page 1 of 2

06 H3 stalling problems

PostPosted: Fri Oct 23, 2015 11:41 am
by Don 03
I Own a Hummer H3 2006. Randomly, traction, failure, reduced, power, stab sys, service. When all them lights come on it stalls. I can be pulling into a parking spot or driving down the highway. After it dies and I try to start it nothing happens the starter doesn't even click. After some time 30sec to 20 mins it will start back up. I have cleaned all the relays and the connector to the ecu and it worked great for 2 days. The code that pops up is lost connection to the ecu. I have seen that other people have had this problem and I called gm they want me to take it to a dealer. I am a mechanic for roush I have talked to the electrical engineers here and my neighbor has owned a shop also and none of us can figure it out so why pay gm to not find it? If someone else has had this problem and can give me some help that would be awesome. Thanks everyone

Re: 06 H3 stalling problems

PostPosted: Tue Nov 10, 2015 9:14 am
by CaddyStrophic
I had an '06 H3 that would do this. I ended up having to replace/reprogram the PCM and I never had another problem with it again.

Sent from my Nexus 6 using Tapatalk

Re: 06 H3 stalling problems

PostPosted: Tue Nov 10, 2015 9:17 am
by Don 03
Thanks I just put a new ingnition switch and that didn't help I was gonna take the fuse box out and clean the snap out of it. But now I will look into a new pcm. Thanks for the help

Re: 06 H3 stalling problems

PostPosted: Tue Nov 24, 2015 6:49 pm
by Don 03
So I been looking into the problem more. Now that's it's colder it doesn't stall unless I just let it ideal for a while. Which makes me think it's something in the ECU that is getting to warm and over heating. Next step is to put a heat sheild around the ECU and see if that helps. If so I will get a new ECU knowing the problem and have the electrical engineers at work take mine apart to figure out what's going on inside and maybe fix it so I have a spare if this happens again. I will keep you all posted on what I figure out.

Re: 06 H3 stalling problems

PostPosted: Wed Nov 25, 2015 4:36 pm
by Mark
Please do keep us posted on the results. Good to have engineers on hand that might be able to figure out the issue so you have a spare.

Re: 06 H3 stalling problems

PostPosted: Sat Jan 16, 2016 2:50 am
by brickey
My hummer is doing exactly the same thing!!
Did you find a definite solution to this problem?
Thanks

Re: 06 H3 stalling problems

PostPosted: Sat Jan 16, 2016 4:57 am
by Don 03
I will let you know the 20th I should have a new PCM in and will make sure that fixes it and if it does I will give you the number to the place I got it from. The PCM I got coming was $200 with life time warranty just have to send the old one back. I did receive one from them and it wouldn't work so waiting on a new one to come in but have the old one in still and with it being colder here in Michigan right now the hummer is driving fine.

Re: 06 H3 stalling problems

PostPosted: Sat Jan 16, 2016 9:56 am
by brickey
Ok. Thank you very much!!

Re: 06 H3 stalling problems

PostPosted: Sun Feb 28, 2016 9:57 pm
by Don 03
Sorry it took so long. So the company I got the PCM from reprogrammed it and for some reason wouldn't adapt to my hummer. So we took it in had one of the new ones reprogrammed and put it now it works good so far. It has only been a week but no problems in the week. I think/hope that fixed the problem for good!!

Re: 06 H3 stalling problems

PostPosted: Sun Feb 28, 2016 10:52 pm
by brickey
Thank you!!
Replaced the PCM on mine also.
Problem solved!!

Re: 06 H3 stalling problems

PostPosted: Sun Feb 28, 2016 10:55 pm
by Don 03
When I called gm about it they said they never heard of this issue which is odd to me because I have seen a lot of people complain about it. I am gonna call back and tell them what the problem was so they know. You should to so there are more then just a few complants

Re: 06 H3 stalling problems

PostPosted: Mon Feb 29, 2016 6:54 am
by brickey
I will do that!!
There is definitely an issue with it.

HEEELLLP!!! 06 H3 stalling problems

PostPosted: Mon Jun 20, 2016 7:44 pm
by GIMike1972
Hello all!

I am new to the forum and a (somewhat) proud owner of a beautiful yellow H3 with 77K miles on it.

Problem is: once it reaches operating temperature it stalls at nearly every stoplight and stumbles whenever RPMs drop below 600. I was once turning to cross a three lane roadway and it stalled in oncoming traffic (really bad). I plugged in my OBD and it read that the thermostat needed replacement. When I replaced that it said the thermal sending unit was the issue. Replaced that too.

Reading all the forum info I could find(so far) I have done the following myself : 1) replaced the battery. 2) replaced the air filter. 3) replaced the thermostat. 3) replaced the thermal sending unit. 4) cleaned the mass air sensor. 5) cleaned the throttle body. 6) pumped ONLY 91 octane and added octane booster to every tank for 3 tanks.

No change whatsoever. Stalls at every stop when the engine is at operating temp. It was throwing absolutely NO ENGINE CODES on the OBD??!!

I felt I have a problem that exceeded my mechanical skills at this time. I took it to a well-known established local dealer: CRAWFORD BUICK/GMC here in El Paso, TX. After their diagnosis I was told it needed to have the camshaft intake /exhaust sensors replaced. Sweet :( - ONLY $1300 to fix and I'm back on the road!! I received a military discount which brought me to @ $1000 out the door. Yay.

The day I picked it up I drove home and was happy for a minute :). The next day I went to a store after a 10 minute drive on the highway and the dang thing stalled in the parking lot. Furious now I returned the vehicle to CRAWFORD BUICK/GMC in El Paso, TX. After a few days I received a call from them telling me that I needed a new cam chain---to the tune of $1500. At this point I felt I had no choice so I paid and left the dealership HOPING I would NEVER darken their door again. Guess what?

YES the GD Hummer H3 died on my way home AGAIN!!!!!!!!!!!!!!!!!!! Returned the truck to CRAWFORD BUICK/GMC who had the H3 for another 2 weeks before I was informed that they had replaced the throttle body, torque converter, and inspected all ground cables to no avail. They informed me that I now need to replace either the heads or the entire freaking engine due to low vacuum. To the tune of $6000-8000 dollars. (For real). :(

Really? After spending $2500 on repairs (apparently stuff that the truck didn't really need) AND they were working with GM engineers to figure out what the heck is going on with this motor??

My question is: has anyone else had an issue like this??????????

Re: 06 H3 stalling problems

PostPosted: Mon Jun 20, 2016 8:03 pm
by Don 03
Sounds like the problem I was having. It ending up being the ecu got to hit and killed it so I got one for 200 paid 100 to have it reprogrammed and works great now!!!

Re: 06 H3 stalling problems

PostPosted: Tue Jun 21, 2016 4:58 pm
by GIMike1972
Sooo, ECU or PCM or are they the same thing? :wall: