Factory Amp?

H2 Specific Information

Factory Amp?

Postby TradedMyWrangler4H2 » Mon Jun 21, 2010 1:37 pm

Anyone had there Amp give them problems? I have an "03 H2, and my amp constantly draws battery power and kills my battery over night if I do not pull the fuse under the hood to my radio. The stealership says I need to replace it (for $1400 for Amp and install), but obviously that would be dumb when I could go all aftermarket with toughscreen and extras for that much or less. I am just curious if anyone else has experienced this problem, and if there were any cheaper ideas or used factory amps out there...thanks fellas. I am hoping to resolve this issue as soon as I get back from this deployment! :wall:
TradedMyWrangler4H2
Trail Novice
Trail Novice
 
Posts: 68
Joined: Tue Jan 20, 2009 9:29 pm
Vehicle: 2003 Hummer H2

Re: Factory Amp?

Postby Robo » Mon Jun 21, 2010 1:58 pm

Seen this before on some of our customer's cars, and you're right, they ain't cheap :wall:
The Constitution of the United States of America and the Bill of Rights guarantees our Freedom and our Rights. They do not protect them.
Protect your Freedom. Protect your Rights.

http://www.nraila.org
User avatar
Robo
Club Member
Club Member
 
Posts: 2252
Joined: Mon Jan 21, 2008 7:44 pm
Location: The Volunteer State
Vehicle: Catch and release H3

Re: Factory Amp?

Postby big2dabank » Mon Jun 21, 2010 2:18 pm

Damn, never had that problem before. Besides trouble shooting the wires on the existing amp I amnot sure where to tell you to begin. Hopefully someone else will have an answer.
BIG2DABANK
05 H2 SUT, Desert Sand

__________________________
Hummer X Club Florida Chapter
Vice-President
florida2@hummerxclub.com
User avatar
big2dabank
Chapter Vice President - Florida
Chapter Vice President - Florida
 
Posts: 1223
Joined: Wed Oct 15, 2008 6:35 pm
Location: Clermont, Florida
Vehicle: 05 H2 SUT

Re: Factory Amp?

Postby TradedMyWrangler4H2 » Tue Jun 22, 2010 11:17 am

Yeah, it just stays powered and won't shut off, so I have to pull the fuse out to cut power. I figure if teh factory amp is that expensive, I will just have to replace the head unit and amp together. I know the facotry head unit isnt strong enough alone to push sounds through the Bose speakers, hence the factory amp.

With that said, anyone know what exaclty will be affected by the removal of the factory amp as far as warning sounds light door open bell, etc? I think a few more little fixes like these and I am gonna stop babying the thing and treat it like I did my Jeep! lol "WHEEL IT LIKE IT'S SPONSORED!" :evil:

Thanks guys
TradedMyWrangler4H2
Trail Novice
Trail Novice
 
Posts: 68
Joined: Tue Jan 20, 2009 9:29 pm
Vehicle: 2003 Hummer H2

Re: Factory Amp?

Postby big2dabank » Tue Jun 22, 2010 11:33 am

Sounds like a relay or something is not working. You could find the power wire for the amp and wire your own relay to be switched with the ignition. Would be a cheap fix if the amp is still working.
BIG2DABANK
05 H2 SUT, Desert Sand

__________________________
Hummer X Club Florida Chapter
Vice-President
florida2@hummerxclub.com
User avatar
big2dabank
Chapter Vice President - Florida
Chapter Vice President - Florida
 
Posts: 1223
Joined: Wed Oct 15, 2008 6:35 pm
Location: Clermont, Florida
Vehicle: 05 H2 SUT

Re: Factory Amp?

Postby Robo » Tue Jun 22, 2010 1:06 pm

big2dabank wrote:Sounds like a relay or something is not working. You could find the power wire for the amp and wire your own relay to be switched with the ignition. Would be a cheap fix if the amp is still working.


I'd like to say so, but it will probably be the amp :(
The Constitution of the United States of America and the Bill of Rights guarantees our Freedom and our Rights. They do not protect them.
Protect your Freedom. Protect your Rights.

http://www.nraila.org
User avatar
Robo
Club Member
Club Member
 
Posts: 2252
Joined: Mon Jan 21, 2008 7:44 pm
Location: The Volunteer State
Vehicle: Catch and release H3

Re: Factory Amp?

Postby TradedMyWrangler4H2 » Tue Jun 22, 2010 4:28 pm

Yeah that will prob be worth a try before I just scrap the Amp all together. Thanks guys. I will try that when I get back home soon. Can't wait! :D
TradedMyWrangler4H2
Trail Novice
Trail Novice
 
Posts: 68
Joined: Tue Jan 20, 2009 9:29 pm
Vehicle: 2003 Hummer H2

Re: Factory Amp?

Postby katman » Mon Aug 15, 2016 11:21 am

My 03 Tahoe did that when I first bought it. I had left a CD in the head unit. Took the CD out, charged. the batt and all was good.
katman
New User
New User
 
Posts: 3
Joined: Mon Aug 08, 2016 3:58 pm
Vehicle: H2


Return to H2 Tech

Who is online

Users browsing this forum: No registered users and 2 guests

cron