ignition switch problem? or?

H3 Specific Information

ignition switch problem? or?

Postby plnnfs H3 » Thu Jul 27, 2017 10:09 pm

Please help this is driving me crazy. So Far it never happens when some one is looking at it. It is very inconsistent. Every 4 or 5 times I shut it off my 08 H3 Alpha it comes back on. Not start but the radio comes on an sometime sets the alarm off. If it does not set off the alarm so I know there is a problem it just runs the battery down. When it does this all I have to do is put the key in and turn it off harder. Once in a while it will not let me lock the doors with the key fob. One Mechanic said it is the the ignition switch and I should go to the dealer. the next told me it was electrical and I should go to an electrical specialist. Both tell me that they will charge by the hour and will let me know.
plnnfs H3
New User
New User
 
Posts: 3
Joined: Thu Jul 27, 2017 3:28 pm
Vehicle: 2008 H3 Alpha

Re: ignition switch problem? or?

Postby Mark » Fri Jul 28, 2017 7:06 am

Have not heard of this one before but I would have two guesses on the issue. Initially I was thinking it was probably a problem with your BCM which is basically the computer that controls all the electronics in the vehicle. If it's the BCM it could either be going bad or possibly the dealer re-flashing it could cure the issue. The BCM is behind the front passenger kick panel, has this area gotten wet at all recently? If the BCM gets wet it can cause all kinds of strange symptoms.

Once you mentioned having to put the key in to turn it back further and not being able to lock the doors with the key fob made me think it's more likely the ignition switch. It is somewhat common for the ignition switches in H3s to wear out and cause issues but normally it has to do with the pass lock system and not being able to start. This is new but your symptoms lead me to think that is the issue. How mechanical are you? Have not had to do it myself but believe it's a relatively simple job to replace. I can find you more details if you want.
Hummer X Club Florida Chapter
mailto:florida@hummerxclub.com
User avatar
Mark
Chapter President - Florida
Chapter President - Florida
 
Posts: 15131
Joined: Sat Apr 29, 2006 5:42 pm
Location: Orlando FL
Vehicle: 09 H3 Alpha/74 Int. Scout

Re: ignition switch problem? or?

Postby plnnfs H3 » Fri Jul 28, 2017 12:08 pm

Mark wrote:Have not heard of this one before but I would have two guesses on the issue. Initially I was thinking it was probably a problem with your BCM which is basically the computer that controls all the electronics in the vehicle. If it's the BCM it could either be going bad or possibly the dealer re-flashing it could cure the issue. The BCM is behind the front passenger kick panel, has this area gotten wet at all recently? If the BCM gets wet it can cause all kinds of strange symptoms.

Once you mentioned having to put the key in to turn it back further and not being able to lock the doors with the key fob made me think it's more likely the ignition switch. It is somewhat common for the ignition switches in H3s to wear out and cause issues but normally it has to do with the pass lock system and not being able to start. This is new but your symptoms lead me to think that is the issue. How mechanical are you? Have not had to do it myself but believe it's a relatively simple job to replace. I can find you more details if you want.


I would like any help I can get. It has never gotten wet unless there is a leak that I have not seen.
plnnfs H3
New User
New User
 
Posts: 3
Joined: Thu Jul 27, 2017 3:28 pm
Vehicle: 2008 H3 Alpha

Re: ignition switch problem? or?

Postby Mark » Fri Jul 28, 2017 12:42 pm

More than likely it is the ignitions switch. Don't have time at the moment but let me search for details on how to change it out later and will post them.
Hummer X Club Florida Chapter
mailto:florida@hummerxclub.com
User avatar
Mark
Chapter President - Florida
Chapter President - Florida
 
Posts: 15131
Joined: Sat Apr 29, 2006 5:42 pm
Location: Orlando FL
Vehicle: 09 H3 Alpha/74 Int. Scout

Re: ignition switch problem? or?

Postby plnnfs H3 » Sun Jul 30, 2017 10:57 am

Mark wrote:More than likely it is the ignitions switch. Don't have time at the moment but let me search for details on how to change it out later and will post them.


Thanks
plnnfs H3
New User
New User
 
Posts: 3
Joined: Thu Jul 27, 2017 3:28 pm
Vehicle: 2008 H3 Alpha

Re: ignition switch problem? or?

Postby Mark » Mon Jul 31, 2017 8:34 am

Sorry for the delay getting back to this but I believe this thread should give you the info you need.

viewtopic.php?f=25&t=13642
Hummer X Club Florida Chapter
mailto:florida@hummerxclub.com
User avatar
Mark
Chapter President - Florida
Chapter President - Florida
 
Posts: 15131
Joined: Sat Apr 29, 2006 5:42 pm
Location: Orlando FL
Vehicle: 09 H3 Alpha/74 Int. Scout


Return to H3 Tech

Who is online

Users browsing this forum: No registered users and 2 guests