Page 1 of 1

Service 4wd light

PostPosted: Tue Mar 17, 2015 9:17 pm
by PedrowifeHH60
Hey yall, Just bought my first hummer h3 and it's a 2007, my service 4wd light comes on randomly and I've had the fluids check and had it hooked up to machine and it had no readings. I read a forum that said to switch it from 4 high lock to 4 low till light goes off and that worked but it ended up coming right back on. I also read to drive for about 100 miles in 4 high lock and I did that and it still comes on. does any one know how to fix this or have any suggestions?

Re: Service 4wd light

PostPosted: Wed Mar 18, 2015 6:59 am
by Mark
Welcome to HXC. I am moving this to the H3 Tech section where you are most likely to get the info you are looking for.

Re: Service 4wd light

PostPosted: Wed Mar 18, 2015 4:07 pm
by ponchoV8
Welcome to the club of warning lights. See my thread if you wanna see the hassle I'm dealing with. Start with the easy stuff you feel you are capable of handling; replacing battery terminals, cleaning negative grounds, etc that have been suggested in plenty of threads regarding these intermittent warning lights. Hopefully some of those little fixes will cure your "Serv 4WD" light. They didn't do much for me so a trip to a good shop is in the future.

Re: Service 4wd light

PostPosted: Wed Apr 01, 2015 12:42 pm
by AlphaChick
having the same trouble. It only started happening after I ha the steering shaft replaced. The light sometimes will go off for a little bit (in the middle of a drive) but usually comes back on.

Re: Service 4wd light

PostPosted: Thu Apr 02, 2015 1:41 am
by Happy Hummer
Sounds like the steering wheel was not held in lock. If it was out of position when reinstalled it might possibly be causing this?

Chris