Oil light and chime

H3 Specific Information

Oil light and chime

Postby MrClark » Wed Jan 31, 2018 12:39 pm

My oil light and chime started going off a few times. So I checked the other threads here so I figured ok I'll change a few sensors
and do away with the annoying chime. I replaced my Cam solenoid, I thought it would relieve my misery. It did for a week. The oil light came back on like most
here in the forums only when coming to a stop after a drive. So I decided to replace my oil pressure sensor as well. So after a few days I thought I was on easy street.
Suddenly today the light came back on with the chime.. My oil level is perfect I change my oil every 5K miles. My engine runs quiet and my operating temp is fine too. No knocks or lifter clicks. My H3 is an 07 3.7 liter 129K miles. My throttle body and MAF sensor are clean. I maintain my truck perfectly. I was about to install a set of Stingers and replace the oem battery clamps. I'm open to you good members advice on What my next step should be. PLEASE!!! I'm afraid I will end up at the dealer. THANKS
CC
MrClark
New User
New User
 
Posts: 6
Joined: Sun Nov 06, 2016 2:52 pm
Vehicle: Hummer H3

Re: Oil light and chime

Postby Mark » Wed Feb 14, 2018 8:11 am

Have you considered hooking up an external sensor to make sure the readings are correct? Possibly the pump is going? Any codes you can read?
Hummer X Club Florida Chapter
mailto:florida@hummerxclub.com
User avatar
Mark
Chapter President - Florida
Chapter President - Florida
 
Posts: 15152
Joined: Sat Apr 29, 2006 5:42 pm
Location: Orlando FL
Vehicle: 09 H3 Alpha/74 Int. Scout


Return to H3 Tech

Who is online

Users browsing this forum: No registered users and 4 guests