H3 intermittent electrical problems

General Discussion

H3 intermittent electrical problems

Postby TrailerQueenH3 » Wed Oct 10, 2012 4:30 pm

To start out ill give you some history of the vehicle.
2007 H3 W/ adventure package
90,000 miles
very little off-roading done (hence my handle)

Three months ago i go out to my H3 road warrior and it wont start when im trying to get to work. Battery isnt dead. so i just take the negative cable off and hard reset everything. hook it back up and im in business.

A few days after that my wife comes home from driving it and the key is stuck in the ignition. im thinking wtf. i walk out there and pull it right out. i thought she was crazy. next morning it wont start again. i notice there are two lights going off in the panel the engine light and a yellow car and lock symbol. ( passive lock symbol). i strugle with it for a few minutes and try to do a hard reset and when i go to start it up i put the key in the ignition and go to crank it and all the gauges and radio and warning light start going crazy. and it still wont start. i get pissed and slam the door... the freller starts to act right again.

i drive it this way for three months with this problem coming and going. i learn how to relearn a key to the passive lock system ( this works sometimes... Turning the key on and off in 10 sec intervals) i hard reset the rig, and when all else fails i slam the door( this surprisingly works wonders).

One week ago i was driving it home from work the parking brake light, traction control light, error message , TSM service waring, came on and off... then all the gauges reset and the dash light went out. all the while the radio was on wide open. and when i get home it want start.

i did some reading and found a thread on a different site that someone was having a similar issue and it turn out to be the BCM ( body control module)... but i dont think this is my problem because the BCM has nothing to do with the parking brake and traction control lights( i found a image online with a diagram of the BMC wiring)

i am ready to set it on fire :wall:

any wrench turner out there with some advice?.... ( should i start the fire from within or put a rag in the gas fill and run...jk)

thanks,
TrailorQueenH3
TrailerQueenH3
New User
New User
 
Posts: 1
Joined: Wed Oct 10, 2012 4:00 pm
Vehicle: Hummer H3

Re: H3 intermittent electrical problems

Postby Robo » Fri Oct 12, 2012 6:59 am

Sounds like you have a low voltage concern. 1st, have your battery checked for voltage AND cold cranking amps ( CCA ). If that ain't it, check the alternator output. Most newer vehicle's start flippin out when the battery or charging system cannot provide the necessary juice for the all of the computers to communicate properly. A good code reader which will provide codes for not only engine and trans, but body codes too, and give DTC's for the ABS, traction control, air bag, etc. If you have multiple codes like that, you probably have low voltage codes too.

PS

The door slamming thing brings some things into thought too, like loose connections and/or damged circuits in a module, especially an instrument cluster problem.
The Constitution of the United States of America and the Bill of Rights guarantees our Freedom and our Rights. They do not protect them.
Protect your Freedom. Protect your Rights.

http://www.nraila.org
User avatar
Robo
Club Member
Club Member
 
Posts: 2252
Joined: Mon Jan 21, 2008 7:44 pm
Location: The Volunteer State
Vehicle: Catch and release H3

Re: H3 intermittent electrical problems

Postby MrRoadWarrior » Mon Oct 22, 2012 7:57 pm

Are you having any problems getting shocked when stepping out of the vehicle?

Robo...couldn't a short to the body create a low-volt condition or simulate one?

If so, I'd pull a door panel...I'm betting you have to slam the driver's door to fix...not others....true?
MrRoadWarrior
Trail Novice
Trail Novice
 
Posts: 30
Joined: Mon Oct 22, 2012 9:18 am
Vehicle: '06 H3, Black on Black

Re: H3 intermittent electrical problems

Postby RKSmith163 » Mon Oct 22, 2012 10:06 pm

Check your battery cables to make sure they are making good contact. It is a known issue with the H3's The smallest deviation in voltages can cause the electricals to go bonkers.
RKSmith163
Trail Novice
Trail Novice
 
Posts: 68
Joined: Sat Aug 01, 2009 9:02 pm
Location: Blacksburg, VA
Vehicle: 2010 Alpha/Offroad

Re: H3 intermittent electrical problems

Postby isoparme » Fri Jan 23, 2015 7:37 pm

hi, have you find the origin? cos i have the same problem actually, thx for your reply
isoparme
New User
New User
 
Posts: 3
Joined: Mon Jan 19, 2015 3:36 pm
Vehicle: h3

Re: H3 intermittent electrical problems

Postby Mark » Fri Jan 23, 2015 7:56 pm

Check your battery to make sure it's good. Also check the terminals, they are poorly designed and can be the cause of a lot of odd electrical issues.
Hummer X Club Florida Chapter
mailto:florida@hummerxclub.com
User avatar
Mark
Chapter President - Florida
Chapter President - Florida
 
Posts: 15135
Joined: Sat Apr 29, 2006 5:42 pm
Location: Orlando FL
Vehicle: 09 H3 Alpha/74 Int. Scout

Re: H3 intermittent electrical problems

Postby isoparme » Mon Feb 02, 2015 5:44 pm

thx , but i chaège the terminal with gold connector and new optoma red battery, so problem stil the same, whe i dpnt seat and turn the key it start all time, if i seat and turn the key it won't when ist cold, and in this case i slam the door and magic ignition is fix... i stil looking and cleaning wires, i pit away the front seat , cleaning wire and mass , but ... don't fix my problem.. i stil looking,

any ideas ?

sorry for my poor english
isoparme
New User
New User
 
Posts: 3
Joined: Mon Jan 19, 2015 3:36 pm
Vehicle: h3

Re: H3 intermittent electrical problems

Postby isoparme » Fri Jun 02, 2017 11:41 am

I have the same problème during 1 year, then my h3 recieve a lot of water from the roof, and the bcm was changed, after that i never have problem whis this until now... because i clean me sunroof and by accidents a recieve 500ml of water near the bcm... and first my keyless stop working (the day after ) i try to clean , open the bcm clean and dry but nothing to do.., the day after , i'm back from event and i stop front of a friend, stop the engine and speak 2 minutes, after i try to start but the engine symbol and passlock red lighting, i go to the battery disconect the red et put in place et the engine start , another day same problem, ... simply to resolve, slaming the door and voila! So realy... i thing the bcm is in trubble, so i try tomorrow to clean the bcm cart whith isopropilique alcool , i tell you what after trying

Envoyé de mon SM-T555 en utilisant Tapatalk
isoparme
New User
New User
 
Posts: 3
Joined: Mon Jan 19, 2015 3:36 pm
Vehicle: h3


Return to General

Who is online

Users browsing this forum: No registered users and 1 guest

cron